16 posts in this topic

So, I installed the WebUI Package onto our Plastic Server (running Server 2012 R2), and I'm assuming I did most of it right. 

Our Plastic Server uses Active Directory Authentication, so when deploying the WebUI package, I selected "ADWorkingMode."

Upon completion of the Web Deploy setup of the WebUI package, I am able to see the Plastic SCM WebUI login page.

However, my credentials do not work.  It keeps saying that the user name and password are incorrect. (Screenshot attached).

I've tried it with my domain credentials multiple ways as well:

This is what I get after 3 different version of my credentials are used back-to-back:

2017-06-15 15:56:16,541 INFO  Global: Application started
2017-06-15 15:56:17,041 ERROR Authentication: Unable to validate user 'CORP\ralley': Access to the path 'plastic4' is denied.
2017-06-15 15:56:24,401 ERROR Authentication: Unable to validate user 'ralley': Access to the path 'plastic4' is denied.
2017-06-15 15:56:32,198 ERROR Authentication: Unable to validate user 'ralley@corp.disti.com': Access to the path 'plastic4' is denied.
2017-06-15 15:57:12,902 INFO  Global: Application recycled

Any help would be great, as I'm struggling with these authentication errors.

WebUIError.jpg

Share this post


Link to post
Share on other sites

Additionally, I'm using MySQL 5.7 as the backend database.  Not sure if that makes a difference when it comes to authentication, but I figured I'd add that as well.

Share this post


Link to post
Share on other sites

Hi,

Could you change the application pool's identity to "LocalSystem".

It seems the use who runs the WebUI doesn't have permissions to access to the Plastic user foder "C:\Users\xxx\AppData\Local\plastic4".

Regards,

Carlos.

1 person likes this

Share this post


Link to post
Share on other sites

That seemed to work!  I'm able to at least login!  Buuuuuttt...it takes me to a repositories list with nothing listed.  And I tested it for giggles, and I can login as anyone I want.  Attached are two screenshots.  One with my actual login, and one with a fake login.  And then I when I try to go to a page for an existing repo that I knowingly have permission to (which is probably blocked by permissions) I get the error page.  Also see below for logs...

2017-06-16 09:10:49,960 INFO  Global: Application started
2017-06-16 09:12:40,869 INFO  Global: Application recycled
2017-06-16 09:12:52,245 INFO  Global: Application started
2017-06-16 09:13:07,526 INFO  Global: Application recycled
2017-06-16 09:13:18,652 INFO  Global: Application started
2017-06-16 09:13:40,433 INFO  Global: Application recycled
2017-06-16 09:14:04,809 INFO  Global: Application started
2017-06-16 09:14:40,810 INFO  Global: Application recycled
2017-06-16 09:15:16,233 INFO  Global: Application started
2017-06-16 09:18:50,052 INFO  Global: Application recycled

PlasticReps2.jpg

PlasticReps.jpg

PlasticReps1.jpg

Share this post


Link to post
Share on other sites

Hi!

 

can you please change the "webui.log.conf" file to increase the log level?

Just change all the "<level value="INFO" />" entries to "<level value="DEBUG" />", then restart the application and share the log with us.

1 person likes this

Share this post


Link to post
Share on other sites

2017-06-16 11:44:41,603 INFO  Global: Application started
2017-06-16 11:44:46,447 DEBUG Global: Time setting user:ralley credentials from request:0
2017-06-16 11:44:47,025 DEBUG Global: Time setting user:ralley credentials from request:0
2017-06-16 11:44:53,588 INFO  Global: Application recycled

Share this post


Link to post
Share on other sites

Ummmm can you send your webui.log.conf file?

I think we are missing log, don't you have more INFO configured?

 

1 person likes this

Share this post


Link to post
Share on other sites

My apologies:

<log4net>

    <appender name="ConsoleAppender" type="log4net.Appender.ConsoleAppender">
        <layout type="log4net.Layout.PatternLayout">
            <conversionPattern value="%date %-5level %logger - %message%newline" />
        </layout>
    </appender>

    <appender name="FileAppender" type="log4net.Appender.FileAppender">
        <file value="bin\webui.log.txt" />
        <appendToFile value="true" />
        <layout type="log4net.Layout.PatternLayout">
            <conversionPattern value="%date %-5level %logger: %message%newline" />
        </layout>
    </appender>

    <logger name="Performance">
      <level value="DEBUG" />
    </logger>
    <logger name="Global">
      <level value="DEBUG" />
    </logger>
    <logger name="Authentication">
      <level value="DEBUG" />
    </logger>

    <root>
      <level value="ERROR" />
      <appender-ref ref="FileAppender" />
    </root>

</log4net>
 

Share this post


Link to post
Share on other sites

Sorry Rod, I missed your answer.

Please change "<level value="ERROR" />" to "<level value="DEBUG" />".

Restart the application and send us the new log generated.

1 person likes this

Share this post


Link to post
Share on other sites

This is the content from the webui.log.conf file:

<log4net>

    <appender name="ConsoleAppender" type="log4net.Appender.ConsoleAppender">
        <layout type="log4net.Layout.PatternLayout">
            <conversionPattern value="%date %-5level %logger - %message%newline" />
        </layout>
    </appender>

    <appender name="FileAppender" type="log4net.Appender.FileAppender">
        <file value="bin\webui.log.txt" />
        <appendToFile value="true" />
        <layout type="log4net.Layout.PatternLayout">
            <conversionPattern value="%date %-5level %logger: %message%newline" />
        </layout>
    </appender>

    <logger name="Performance">
      <level value="DEBUG" />
    </logger>
    <logger name="Global">
      <level value="DEBUG" />
    </logger>
    <logger name="Authentication">
      <level value="DEBUG" />
    </logger>

    <root>
      <level value="DEBUG" />
      <appender-ref ref="FileAppender" />
    </root>

</log4net>

My log for the "webui.log.txt" is as follows:

2017-06-20 11:12:37,215 INFO  Global: Application started
2017-06-20 11:12:37,700 DEBUG UserInfo: Time retrieving CurrentUser 0 ms
2017-06-20 11:12:37,715 DEBUG ServerAlias: Getting the server config for repository server 'localhost:8087', config file 'serveralias.conf'
2017-06-20 11:12:37,731 DEBUG PlasticProtocolConnectionCreator: Create connection to localhost:8087 took 16 ms
2017-06-20 11:12:37,731 DEBUG PlasticPipe: CmCallContext sent to server on connection creation
2017-06-20 11:12:37,762 DEBUG PlasticPipe: sentb:    68|recb:     3|prt:      47|CheckConnection|localhost:8087
2017-06-20 11:12:37,762 DEBUG CmConnection: Protocol for localhost:8087 is Plastic. 63 ms
2017-06-20 11:12:37,762 DEBUG PlasticPipe: sentb:     2|recb:     2|prt:       0|CheckConnection|localhost:8087
2017-06-20 11:12:37,793 DEBUG Global: Time setting user:ralley credentials from request:0
2017-06-20 11:12:37,793 DEBUG PlasticPipe: sentb:     2|recb:     5|prt:       0|GetRepositoryList|localhost:8087
2017-06-20 11:12:37,793 DEBUG PlasticPipe: sentb:     2|recb:     2|prt:       0|CheckConnection|localhost:8087
2017-06-20 11:12:39,903 DEBUG Global: Time setting user:ralley credentials from request:0
2017-06-20 11:12:45,356 INFO  Global: Application recycled

Share this post


Link to post
Share on other sites

I can't see errors in your log file.

Is the Plastic SCM server running at the same machine on the 8087 port?

Which Plastic SCM user is configured for the WebUI, during the installation the wizard asked for one. Is it having enough Plastic SCM permissions? Can you try to configure a client with that user and run a "cm lrep" command to check it's able to retrieve repositories?

1 person likes this

Share this post


Link to post
Share on other sites

Yes, the Plastic SCM server is running on the same machine (Disti-Plastic-1 is the hostname) on the 8087 port.  I configured the WebIIS, Plastic SCM Server and WebUI on my username.  However, when I installed via the wizard, I didn't use my credentials, as it said it was only needed for "charts," and I didn't think I needed to store my credentials in the config.  

I can try to add my credentials if needed, but at the same time, I want all of our users to be able to login, not just me.  We have 40 active licenses here, and we want our users to be able to http into Plastic SCM.

H:\>cm lrep

Repo1 @localhost:8087
Repo2 @localhost:8087
Repo3 @localhost:8087
Repo4 @localhost:8087
Repo5 @localhost:8087
Repo6 @localhost:8087
Repo7 @localhost:8087
Repo8 @localhost:8087
Repo9 @localhost:8087
Repo10 @localhost:8087
Repo11 @localhost:8087
Repo12 @localhost:8087
Repo13 @localhost:8087
Repo14 @localhost:8087
Repo15 @localhost:8087
Repo16 @localhost:8087
Repo17 @localhost:8087
Repo18 @localhost:8087
Repo19 @localhost:8087
Repo20 @localhost:8087
Repo21 @localhost:8087
Repo22 @localhost:8087
Repo23 @localhost:8087
Repo24 @localhost:8087
Repo25 @localhost:8087
Repo26 @localhost:8087
Repo27 @localhost:8087
Repo28 @localhost:8087
Repo29 @localhost:8087
Repo30 @localhost:8087


I apologize if my responses seem somewhat oblivious, but Plastic SCM was a huge project that was thrown at us, and none of us have any experience working with it.  Your help is greatly appreciated.

Share this post


Link to post
Share on other sites
3 minutes ago, rodgeralley said:

I didn't use my credentials

Aha, that might be the issue.

3 minutes ago, rodgeralley said:

I can try to add my credentials if needed, but at the same time, I want all of our users to be able to login, not just me.  We have 40 active licenses here, and we want our users to be able to http into Plastic SCM.

Yes, please. Reinstalling the web app is the fastest way. Remember al the steps you followed, app permissions and so on.

The user the wizard requests is for internal operations, the rest of Plastic SCM users will be able to log in, no problem at all.

7 minutes ago, rodgeralley said:

I apologize if my responses seem somewhat oblivious, but Plastic SCM was a huge project that was thrown at us, and none of us have any experience working with it.  Your help is greatly appreciated.

Hey! No problem, here to help!

1 person likes this

Share this post


Link to post
Share on other sites

Still the same issue.  I don't have any repositories showing up, and I can still log in as any random username I choose.  Also, when i put my credentials in on the WebDeploy of WebUI, it saves it in clear text in the web.config file.  I definitely don't like that, as these are my domain credentials.

Share this post


Link to post
Share on other sites

Hello Rod,

you can alternatively use a different user for that purpose, it won't require a license since it will just run RO operations.

BTW, I've sent you a detailed guide of the installation. Hope it helps.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now