BrendanLobuglio

Never Prompted for Encryption Password

2 posts in this topic

As part of my onboarding for a new job, I'm cloning our project repo from a Plastic SCM Cloud server. I have created an account, and registered with the organization just fine. However, when I attempt to pull the main branch, I was never prompted to provide the encryption password for the organization; accordingly, the pull fails with a "Data cannot be decrypted, please ensure your encryption key password is correct" error message. Forgive me if I'm missing something obvious here, but where can I enter or change the password?

If it's at all relevant, when I created the default organization for my PlasticSCM account, I did not check the box to encrypt information for that organization. Frustratingly, your interface at http://cloud.plasticscm.com/organizations/edit does not have the ability to change this setting. I wouldn't expect this to matter, given that it's my membership in the company organization that gives me access to the repo, but I felt it worth mentioning all the same.

Let me know how I can best remedy this situation!

Capture_1.PNG

Capture_0.PNG

Share this post


Link to post
Share on other sites

Hi Brendan,

I know you also contacted us through mail so here you have Pablo's answer just in case anyone else find it useful.

Hi Brendan,

1. If your organization is not encrypted, then it won't ask for a password, as simple as that :-)

2. In case it is: 
2.1. Are you the admin of your server? (You know, owner of the repserver). If so, you will be prompted to enter the password. Otherwise, you can't configure the server from the client side and you won't.
2.2. It is all explained here (hopefully enough :P) https://www.plasticscm.com/documentation/cloud/plastic-scm-version-control-cloud-guide.shtml#EncryptalldatagoingtoPlasticCloud


Now, why we can't change the setting? Very easy: if your data is encrypted, there is no way to decrypt it on the server side, so if you change the setting, data will be unusable. Same for non-encrypted to encrypted. So, it is a quite sensitive setting. You must set it correctly at the beginning.

In addition to that, check in the following directories a file called "cryptedservers.conf":

  • C:\Users\Your_USER_name\AppData\Local\plastic4\
  • c:\Program Files\PlasticSCM5\server

If you find it please close the GUI and remove them. Then try the pull operation again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now