dperham

plastic client not using plastic-global-config/allrepos/serveralias.conf

3 posts in this topic

I have created a serveralias.conf that works when installed in my plastic4 user directory per https://www.plasticscm.com/documentation/administration/plastic-scm-version-control-administrator-guide.shtml#Chapter13:Supportalternativeconnectionstothesameserver

However, now I am trying to create a global configuration so that all users get this by default. I created a repo, plastic-global-config, such that I have the following file

plastic-global-config/allrepos/serveralias.conf

 

*This does not work*  After restarting my plastic client,  it seems that the global serveralias.conf has no effect.  Thanks in advance.

Share this post


Link to post
Share on other sites

SOLVED.   This did not take effect the first time.  I had to reopen the plastic client for the change to take effect.

  1. created plastic-gobal-config repo
  2. created allrepos/serveralias.conf
  3. opened plastic client (server aliases were not in effect for this session)
  4. A file appeared on my filesystem 
    C:\Users\<my-name>\AppData\Local\plastic4\globalconfig\ssl_<my-server>_8088\allrepos\serveralias.conf

      

  5. Plastic client was restarted and everything worked correctly

Share this post


Link to post
Share on other sites

Yep! You need to restart he GUI in order to trigger the download.

Happy to know it works for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now