Jump to content

andsee

Members
  • Content count

    23
  • Joined

  • Last visited

  • Days Won

    1

andsee last won the day on June 18 2013

andsee had the most liked content!

Community Reputation

5 Neutral

About andsee

  • Rank
    Member
  1. andsee

    Finding pending changes stuck?

    Finally back up and running. Restarting the server and updating to latest 7 had no effect. To make progress and get the pending changes view working I deleted the .plastic file within the project and then created a new workspace in the same location and did a get. I checked in a few files fine I then proceeded to check in sections at a time (1Gb / 100,000 files or so a time). This would cause 7.0.16.2063 to crash and exit every time, I sent the crash report via apple. Switching back to 6.0.16.1792 and the checkins completed. So there may be an issue within 7 when checking in large numbers of files.
  2. This morning has been spent trying to get Plastic to check in ~5GB of changes with no success :-( It looked like Plastic was crashing so I force quit plastic a few times and then decided to roll back to the last v6 version of Mac Plastic. Still this was taking a long time, however on looking at the Activity monitor I could see plastic was busy (100% of one cpu core) and the disk access was slowly going up. So I left it for an hour or more and eventually it started to show the uploading to server progress bars and no longer showed not responding in the force quit dialog. The bars slowly filled up until full and then it decided that it was going to cancel the operation. So I decided to move all these new files out of the project and add just a few at a time. Unfortunately I've not been able to get pending changes to show any changes it just shows 'finding changes....' It's not accessing the HDD or network but it's CPU is at 100% :-( As I test I thought I'd copy the whole project to another folder to see how long it should take to access all data (14GB) and it took just over a minute. cm iostats Performing network tests with server: xyz.com:8087. Please wait... Upload speed = 606.64 Mbps. Time uploading 16MB = 211ms. Server: xyz.com:8087 Download speed = 221.84 Mbps. Time downloading 16MB = 577ms. Server: xyz.com:8087 Performing disk speed test on path: /var/folders/7d/0592g77j6fq_byykt4rvvvw40000gn/T/PlasticSCM_IOStats. Please wait... Disk write speed = 455.516014234875 MB/s. Time writing 512MB = 1124 ms. Disk read speed = 1333.33333333333 MB/s. Time reading 512MB = 384 ms. It's now 20 minutes since I switched to the Pending Changes tab and it still shows 'finding changes and 100% cpu with no further disk or network access' This occurs in version 7.0.16.2063 and 6.0.16.1792 Andy
  3. Great to hear you're aware of the issue and are working on a fix. Over to my backup machine until then. Thanks Andrew
  4. I'm using Plastic 6.0.16.1614 on Mac OS and have just upgraded to High Sierra and it looks like the Pending Changes window does not work. So on one project which had some changes, the window shows nothing other than the blue 'Finding changes in the workspace...' box at the bottom, and I've left it hours. As another test I created a workspace for a small repository that was not on this machine and changed to the latest change set which correctly got all the files, however pending changes shows the whole directory '.' as being deleted: Also if I edit a source file it does not show up. I also unticked the Miscellaneous option 'Compare file contents instead of timestamps', but this made no difference. A tad stuck....
  5. I'm trying to connect to a second server via MacPlastic, but whenever I enter the details in the repositories window I just get a spinning progress indicator. I'm not sure if any special steps are required, I had to create extra profiles in the PC version but can not find this option in MacPlastic. Note that the normal server that I usually use is offline at the moment so it's also possible that MacPlastic is busy trying to talk to that. I've tried changing the Configuration in preferences to the second server but that just shows Connecting for ages before timing out. I am able to connect to the second server on the PC without issue
  6. andsee

    Accessing projects on different servers

    Perfect thank you. I had my server in that list but had not ventured to the edit window and the "Automatic" option was the key.
  7. Could tell me how to configure my plastic clients so that they can use repositories on different servers. I've tried creating a new repository on the other server but that rightly complains that it already exists but creating a workspace only shows repositories on the one server you get to set in the client configuration app. I've seen references on the forum to a plastic.servers file but can find no documentation on this so don't know if it's a current option, but it sounds like I may need to manually add extra servers to the configuration somehow...
  8. andsee

    Unity3D plugin no longer works

    Quick question to clear pricing up. You mention the following as all that's required: Unity Pro (Unity charges about $1500 per developer, correct?) Unity Team license (Unity charges about $500 per developer) One of the commercial Plastic SCM licenses (it can be a yearly subscription). Where does the plugin https://www.assetsto...#/content/13429 come in this? Do we also need to purchase this from the asset store for each user?
  9. I totally understand the situation regarding Plastic needing to make some money on this integration. I thought I'd explain why I came so close to purchasing the required components from Unity and Plastic but stopped: With the community edition of Plastic I can have occasional freelancers or production accessing the repository and stay within the 15 users. Now I have two full time developers for which I'd be happy to pay the full Plastic license and start using the plugin etc. But I'd still like to be able to allow 13 lesser users to access the server. So basically, a plea, please allow us to define a license based on the connected user. This would convert us from a free user to a paid user and then over time it's likely that the number of users we need full non community license for would increase. Currently it's unlikely to until we need 15 or more users.
  10. andsee

    GitSync misrepresenting Git Merge

    Shall follow up via email
  11. We have just started using GitSync and quickly run into an issue where Plastic shows a git side merge as having deleted several files, but the files exist git side. The above shows the plastic view changeset 4 is where the issue lies. The above is the same view within Git. None of the change-sets affected the files that disappeared. Changeset 2 & 3 are shown swapped in chronological order in git. I'd be happy to do a remote desktop if anyone at Plastic want further information etc. Andrew
  12. I've just setup a new repository and successfully populated it from Git on beanstalk. I created a couple of branches and did some work in them and now wish to submit that work back to git. However whenever I select Sync with Git I get the error message: The sha for the revid:xxxx was not found
  13. andsee

    Repository suddenly disappeared

    Attached is the requested log, hope it helps you work out what happened. The workspace that went missing is called MuHa ChannelCall.log.zip
  14. andsee

    Repository suddenly disappeared

    Ah yes, sorry, I had a search on (obviously better search than my first attempt before posting the question) which had filtered the posts. Never mind. Thanks for the quick reply, cm addrep has us back up and running. I'll grab that log when I have access to the server again later today, hopefully we can identify the issue. I've confirmed with the other two users that they did not knowingly delete the repository, indeed they said they didn't know how to and they don't even access the repository area of the interface.
×