Jump to content

Search the Community

Showing results for tags 'branch explorer'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Plastic SCM
    • General
    • Installation and configuration
    • Unity 3D
    • Plastic SCM on Mac
    • Plastic SCM on Linux
    • Gluon
    • Git interop
    • Integrations
    • Community Edition
    • Branching and merging
    • Announcements
  • Plastic SCM 4.0 Beta (Closed)
  • Plastic Cloud
    • General
    • Configuration
  • SemanticMerge
    • General
    • License
    • SCM's configuration
    • Share your experience!
    • External Parsers
  • GitJungle
  • Method History for Subversion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 25 results

  1. Hiho. Could we please have changeset numbers shown in the branch explorer? It's very disorienting and compicated to find a specific changeset number without them. Also, you already HAVE those implemented, as they are shown in the "View history as 2D revision tree" option for items. So let us have them in the regular branch explorer as well (at least optionally). Currently, you have to manually find them by constantly clicking, checking, scrolling a bit, clicking again, etc. Also, may I suggest to increase the font size for the dates row in the branch explorer? If you use a zoom level where you see a decent portion of your branches (=say, a width of about 20-25 changesets), the date is already almost intelligble. If you zoom in so that you can easily read the date, you're stuck with a section of only 10-15 changesets, which are uncomfortably few, IMHO. Even with just a single commit per day there is still enough space in that row for a bigger font. BTW, thanks for now auto-enabling the "Display only relevant changesets" option when using "View history as 2D revision tree", resp. now storing this option individually for the "normal" branch explorer and the file history. It was very tedious having to constantly switch between them :-) EDIT: Apologies - I just remembered you also have a uservoice site. The request already exists there, near the top of the second page: https://plasticscm.uservoice.com/forums/15467-general/suggestions/8876401-show-changeset-numbers-in-branch-explorer Thanks a lot! :o) Cheers, Wolfram
  2. Hi, I already did several check-in, but suddenly when i open the branch explorer, it shows "No data found. The Server did not return any data for the specified date filter", in the Change-sets tab also empty. when i opened the pending changes tab, and clicked the refresh button, there is no pending changes item displayed... How could this happened?, and what is the solution ?? FYI, I use 4.1.10.411 Gotham Version. my backend is mysql. Thanks..
  3. Client / Server Version = 6.0.16.866 DB = Jet Anytime I try to access the branch explorer I see an error box saying " There has been an unexpected error " The method or operation is not implemented". For more information check the server log. I can create top level and child branches in the Branch section of the client without any issue but as soon as I go into the Branch Explorer that when that error comes up and I cannot see nor do anything. Here are the server logs: ***DEBUG LOG*** ***ERROR LOG***
  4. David R

    Overlapping changesets

    Other people on the team used the new 'merge changeset to' feature to move a main branch changeset to a new branch. Now in Branch Explorer the main branch and the new branch overlap so they cannot be moved using relayout mode. You can just about see overlapping labels and when you right click it shows the two changesets. Apologies if my terms are incorrect as I am a new Plastic SCM user. 5.4.16.802 on Windows 7 and Windows 10. How do we separate the changesets? TIA David
  5. Wolfram

    Bookmarks are not persistent?

    Hiho. When using the bookmarks in the branch explorer, they reset every time I re-open the client, or even the branch-explorer tab. Is that intentional? I'd find it preferrable if they are stored locally between sessions (e.g., when continuing the next day etc.) Note I do NOT mean/want to use labels here - bookmarks are great for temprarily (and locally!) tagging certain changesets in individual workspaces - labels are global:
  6. Hiho. Can we pleeease have chageset numbers be shown in the branch explorer? It would incredibly help when navigating large projects. Maybe optionally, via a toggle under "Display options". You have the functionality for that already in place: When showing the history of a file as "2D revision tree", you'll see a branch-explorer-like window, but it has changeset numbers underneath each changeset. Thanks! :o)
  7. Twice in the last month or so I've had an issue where the Plastic client won't show me the branch explorer. When I view the branch explorer I get a message that says "Exception has been thrown by the target of an invocation. Server: plastic://localhost:8087. Object reference not set to an instance of an object." This doesn't happen for all of my repositories, but has happened to the same one each time it has occurred. The first time it occurred, I ended up deleting the local repository and workspace, and creating new ones, then resyncing with the remote repository. I would prefer to not have to do that again. I am using sqlite backends, if that helps. Today when the issue occurred, I was using Plastic without issue, then restarted my computer and Windows installed an update. All attempts to see the branch explorer afterward have resulted in the error. I have enabled logging for the client and looked through the log for when the error occurs. Here is the section around where it happens. Thank you.
  8. Hello! I have noticed recently that Plastic does not remember options in branch explorer. I make changes to display options, or tick the 'color by user' option, but after restart they are restored to defaults. Another thing is that the options secion visibility is not remembered too. I want to have this section visible in branch explorer, but I always have to show it after starting Plastic. Same case with other buttons in Branch Explorer: Navigator, Statistics, Legend. The version I'm currently running is 5.4.16.771.
  9. Hey there, I've been using plastic scm client from a windows pc for the longest time and the experience has been quite nice. I've recently migrated to mac, and the UI aren't quite identical. Specially, in the Changesets tab, is there any way to see on which changeset am I currently active? On a windows pc, active changeset used be in in bolded text.
  10. This is a minor issue, but let it be noticed. When you create a new branch in a repository, it should be displayed in a column that represents the current date, right? But instead it appears in the same column where the latest available changeset is. By the latest changeset I mean any changeset in any branch of the repository. Let's say, the latest changeset is created 2014.08.01, and you create a new branch (from any changeset in the repo). It appears in the 2014.08.01 column instead of the 2014.08.21, which represents the current date. Please see the picture.
  11. cidico

    This is why I love Plastic

    Hi! I just want to share a picture... I'm working on a company that has a well define software development process. They use Git as SCM tool and I'm using Plastic (of course) to sync with Git. Take a look: The label is the latest version sent to test team and the branches are the bugfixes we're working on! The mere possibility of using SVN (as people wanted to...) on this kind of environment gives me headache so strong I can't even describe...!!! This is perfect. To the last detail! Thanks Códice! You make my life easier than ever!!!
  12. jdyeager

    Unity3D Branch Explorer Freeze

    Any time I try to use the branch explorer from the Unity3D plugin on a Mac, the window opens but then freezes. Usually I cannot do anything with it at all (including closing it or dragging it on the screen by the title bar). Sometimes I will be able to start moving the scroll bar up or down, but then all input will stop. My only option when this happens seems to be killing XQuartz. Any ideas on why this might be happening? Or where I should be looking for any errors that might be thrown?
  13. tom.peters

    No scrollbar on 'Color by User'

    Howdy! We recently upgraded to 5.0.44.537. I do not recall if this was an issue, previously, but there is not was to scroll through the users on the Branch Explorer Options 'Color By User'. I tried resizing and maximizing the screen, but the vertical scrollbar never appears. Thanks, Tom
  14. JakubH

    Update with newer changes

    I like the new feature of looking for newer changes in repository while showing pending changes. However when some new changes appears and I perform and update to them, my workspace selector doesn't change. So according to branch explorer I am at the last changeset, but according to selector, I am still in the past. If I now perform an update operation, it gets me back to the former changeset. It is confusing. Especially in combination with the Visual Studio integration, where Update is named Update to Latest version. It moves me to the past, actually. That's stupid.
  15. I am using the 'Branches with pending merges rule' under Conditional Formatting. It seems to work most of the time, but not all of the time. I have some cases where a child branch has been created, changesets checked in, and the branch merged back to its parent, but the color has not changed back to the default branch color. At first I thought I saw a pattern where the color would not change back if there were multiple merges to or from the child branch, but upon further examination I have found other child branches that have had multiple merges to and from, but the color has changed back to the default. How is this supposed to work? Should the color change back when the latest changeset on the child branch is merged to it's parent branch (or any ancestor branch, for that matter)? Or am I misunderstanding this feature?
  16. I have one reproducible crash here. I have imported our repository with very long history (almost ten years of development). When I set the date filter in a branch explorer to the full range, the Plastic client crashes. There is an unhandled StackOverflowException in libplastic.dll. I can sent you a minidump (without heap at least), if it helps.
  17. EdDev

    Branch Explorer Filter

    Hi, Is there an option to filter out branches/objects from the Branch Explorer window using the Attributes? I manage to use attributes to mark colors on the branches, but was unable to fins a way to make some disappear. Is there such an option? Thanks, Ed.
  18. I have a small question / suggestion to the branch explorer. Nearly everybody here, who I was showing Plastic to, is confused with a direction of arrows a bit. I am OK with a merge link direction (from source to destination), but I don't like links from child to parent. It would be nice to have arrows from parent to child instead. I know about a hidden option to change the direction for merge links as noted here: http://codicesoftware.blogspot.com/2012/02/arrow-story.html. But I would like to change the direction of arrows of "parent links" instead of merge links. Is there an option to do that? Or could it be added?
  19. gregsohl

    Workspace house on wrong branch

    It seems the little house that shows the current changeset and branch that your workspace is pointing to in the BranchExplorer has a problem. After creating a branch from main (Task47) I right clicked on Task47 and switched my workspace to it successfully. However the little house stays on the changeset back on the main branch. You can see from the selector details at the top of the screen that my workspace is on /main/Task47, but the house is not.
  20. I'm simulating the effort a developer would take in a fully distributed model to pull the main branch to their local repository and begin work on a task. There is an aspect of the Branch Explorer presentation in this sequence of steps I find confusing and want to ask about it. Here are my steps: 1. Create a local repository (Name: default) 2. Create a workspace on new local repository (Name: "doddent matter") 3. Set up Sync Replication between local repository (default on GSOHL-DT) and master server repository (default on GSOHL) 4. View pending incoming changes. Pull /main branch from master to local. 5. Open Branch Explorer on workspace "doddent matter". When the new local repository is created in step one, I get an empty root changeset. This is expected. After pulling the /main branch from the remote, I end up with a strange layout in the Branch Explorer, since it is ordered by date only, where that original root changeset now appears on the right side of the graph. It took me a bit to figure out what that empty changeset all the way on the right edge is. Can't tell where its arrow points since it overlaps all the other arrows. I need to basically ignore it, since in a Branch Per Task model I need to create a branch on the last changeset that came from the Master's /main branch. Fine if I choose the branch, not fine if I choose the visibly "most right" changeset, which is really the empty root. How can I make that empty root less of a visual problem? Can't delete it, its the root. Thanks. Greg
  21. Plastic Men, I recently was experimenting with attributes and created one called "Branch Status" and gave it a value. I created a conditional format rule in the Branch Explorer and it appeared to work as it highlighted the branch with the attribute applied to it. I just deleted the attribute this morning and had to do a restart. I've been attempting to open Plastic.exe but it keeps crashing on me... I even installed the latest version it it also is crashing. Here is the debug info: Codice.CM.Common.CmException was unhandled Message=The specified attribute realization can't be found. Source=libplastic KeyMessage=ATTR_NOT_FOUND StackTrace: at np.h() at System.Threading.ExecutionContext.runTryCode(Object userData) at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData) at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state) at System.Threading.ThreadHelper.ThreadStart() InnerException: I also created a Plastic.dmp file so I'm not sure if you can use it or not. Its 300MB so, I can't upload it here. Suggestions?
  22. Hi guys, when i switch my workspace from one branch to another using the branch explorer the colors of the branches are not updated. For example: I use the predefined format rule: "Active branch(es) in this workspace" to highlight the active branch i'm working on. After i switched to another branch i need to press the refresh icon in order to update the colors correctily. (my version of plastic scm is: 4.0.239.9) kind regards, BB
  23. Hi! I noticed something very interesting today... I work a lot at home in my project and I created a bunch of branches at home. At home, my username is "Plácido Bisneto" and at company is "pdinelli". I was doing some conditional format in my branch explorer and created the following filter: owner ='pdinelli' or owner='Plácido Bisneto' (this apply the black color to the branch's background). But I'm an error message is displayed because the user "Plácido Bisneto" is not at my company network. The "funny fact" is that Plastic knows the user that "own" the branch. It shows the owner correctly when I display the branch's detail. But it seems to look in the the user's list of my pc (at company's my domain) where my home user does not exists. The same happens at home.
  24. Can I cause the branch explorer to show more characters of a label name before changing it to ... ?
  25. Been using Plastic SCM for a bit now and like it very much! But just noticed an oddity in the branch explorer. I just checked in a changeset which received a timestamp of "10/20/2011 5:31:43 PM" (as shown in the changesets panel). But when I look in the Branch Explorer, this changeset is listed under the date column 10/21/2011 (tomorrow!). Here again, if I click on the changeset in the explorer, the properties show the correct createion timestamp as listed above. See attached image. Am I missing something or is this a bug in version 3? Not looking for a fix in 3 with 4 coming out... Steve PS - I took a look at the 4 beta yesterday and its looking quite nice! Can't wait for the release...
×