Jump to content

Search the Community

Showing results for tags 'linux'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Plastic SCM
    • General
    • Installation and configuration
    • Unity 3D
    • Plastic SCM on Mac
    • Plastic SCM on Linux
    • Gluon
    • Git interop
    • Integrations
    • Community Edition
    • Branching and merging
    • Announcements
  • Plastic SCM 4.0 Beta (Closed)
  • Plastic Cloud
    • General
    • Configuration
  • SemanticMerge
    • General
    • License
    • SCM's configuration
    • Share your experience!
    • External Parsers
  • GitJungle
  • Method History for Subversion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 31 results

  1. Hi, I'd like to know if it is possible a way to manage more than one PlasticSCM server on a Linux machine with CentOS 6.3. In my office we have several projects that would be interested in connecting to their respective PlasticSCM servers. I've read this topic: But it seems a little tough to me. Is there any other easier way, or is this the only way we currently have to manage several servers in one single machine? Thanks for your help. Regards.
  2. Hi, I have manually installed plastic 5.4 on a Debian 9.3 machine recently and I am in doubt of how to manage which user has license access. I found this comment "Just install plasticscm-client-core" here http://blog.plasticscm.com/2016/01/how-to-manage-plastic-scm-licenses.html, however, that does not make sense that I need the client version of plastic in order to manage user licenses and I am afraid that I will get version mismatch if I use apt-get to install the client? I have found that each repository in the database has a table for user access and I think that is it, however, I would like to know whether there is another way than manually writing some queries to alter the tables, if that is even what I need to do :D? Side question is whether there is an option to install older versions of plastic using apt-get or similar if I have to do another time?
  3. Hi As far is I know the webadmin page cannot be accessed via https / ssl yet. As I'm currently running my plasticscm on an linux server with nginx handling all incoming requests (and requires ssl for all ports) i was trying to get access the webadmin via a proxy forwarding. (internally nginx connects normally in non-ssl way the webadmin-server) Unfortunately the webadmin server does not accept this somehow (get a 404). I assume the webadmin server blocks proxy requests but it could also be that my nginx config is not properly set up. Or do i have to wait until the webadmin supports ssl-certificates? best Fabian
  4. Hello, I'm new to plasticscm and I'm trying to setup RepliKate on my ubuntu server but I'm having trouble with the command getting stuck waiting for my cloud credentials and I couldn't find how to work around this problem. Here is what I've done so far: 1. Compiled RepliKate,copied the files to /opt/plasticscm5/replikate and set proper permissions: 2.Executed RepliKate using plastic's copy of mono: 3. The command gets stuck there and if i try running the last printed line, i get the following: I'm assuming the same prompt happens during RepliKate execution but I cant find how to fix this. Any suggestions? Thanks =)
  5. When running gtkplastic and connecting to a server it fails to accept the SSL certificate. It asks me to accept the certificate twice (I press Yes): Then it shows this error message: When I try running clconfigureclient on the command line I get no chance to accept the certificate and get errors too: When I run as sudo the same error is shown: But when I run 'sudo gtkplastic' I can accept the certificate and it actually works. The issue is likely due to insufficient privilege but the error message does not tell me that, also I do not understand why running 'sudo clconfigureclient' does not work if it is a privilege issue. Please fix this issue or at least provide a proper error message.
  6. Hello, I am currently trying to setup JIRA and got to my next step of integrating with plastic. We use Linux machines for development and when I went to go set up the preferences for issues tracking I noticed that they dont seem to exist the same way as the windows client. I have 5.4.16.689 currently. And i do see there was an update recently, but I did not expect that to add this functionality. Is there a way to set up issue tracking on this version of the linux client? Should I just downgrade back to an older version of the linux client? Thanks for the help, Evan
  7. Hi ! I would like to change global perlmissions for users of my plastic servers, allowing them to "move" any object they want in the repositories. For example i've got a file named "file.php" and I am the owner of this file. If someone wants to rename it to "awesome-file.php", then they are prompted that they have not the rights to do it. Client side I can define rights file by file in the repositories, allowing users to move them (see attachement), but I would like to define it by default from the server side directly. Where can I manage the global users rights / permissions on my server ? Note : I'm on a linux Server.
  8. hi all we just purchased a team licence for our little game dev studio and the main server is running without issues on linux ubuntu 16.04 i want it to replicate automatically on the backup server (another machine under linux ubuntu 16.04) i already followed the install steps from : https://www.plasticscm.com/plastic-for-linux/ubuntu-16.html for the backup server and created a "plasticscm" user on both sides... so what s next please ? :-)
  9. Greetings, I'm trying to move an installation from Windows 7 to Manjaro, an Arch based distro. There is no pacman or AUR package for Plastic, so I had to install manually with the binaries packages. I followed the readme in the scripts folder and managed to get the server running, as well as the gtkplastic client. However, I'm unable to find the repositories in the client, and if I try to search directly for them, by specifying the server name, I get the following error: No channel found trying to connect to [my-server-name] I'm worried that I edited the db.conf file badly, by following the Windows version that I had, or that I can't simply transfer my previous sqlite repositories. Here is the db.conf file: <?xml version="1.0"?> <DbConfig xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"> <ProviderName>sqlite</ProviderName> <ConnectionString>Data Source={0};Synchronous=Off;Pooling=true;</ConnectionString> <AdminConnectionString /> <DatabaseCreationCommands /> <DatabasePath>/home/tralen/Principal/Repositórios</DatabasePath> <DatabasePrefix /> <DatabaseSuffix /> <DatabaseCollation /> <ColumnCollation /> <MaxCachedTrees>50</MaxCachedTrees> <LastUsedCsets /> <LastUsedCsetsLoad>-1</LastUsedCsetsLoad> <FullTreeRevisionsLoad>20000</FullTreeRevisionsLoad> </DbConfig> Thanks for any assistance. Edit: I've found that I also cannot create a new Repository, I get a "Connection Refused" error.
  10. I can't find the code review features in the linux client. Is there anything to do to enable it or is it missing ? If it's missing, where can I get a list of the missing features present in the Windows client but not on Linux or Mac ? Thanks, Fabien
  11. Hello, We have been running CentOS 7 successfully, but the server has not been automatically starting up with the legacy init.d startup scripts. Do you have a ".service" script available to use with "systemd" startup that provides the same functionality? Thank you!
  12. kennethharder

    z error on Debian 8.2

    Hey awesome plastic peps, I have been trying to setup the plastic client on a virtual machine running debian 8.2. When I run any of the commands that I know; e.g. lrep or mkwk, I get a "z"-error. I have attached a log cm.log.txt. Since I could not use apt-get, presumably because I am running debian 8.2, I have installed mono as suggested here http://www.plasticscm.net/index.php?/topic/2193-install-on-ubuntu-1404/ and the plastic binaries using this link https://www.plasticscm.com/download/downloadinstaller/5.4.16.717/plasticscm/linux_x86/clientzip?Flags=None, which might have affected the installation?
  13. Hi, Shelves control seems not to be exposed yet in the GUI of the GTK client and I was looking for a means of managing them using the CLI. I didn't find anything in the docs and the CLI help to list existing shelves. I found out that the following does the job : cm find shelve --format="{shelveid} {comment}" But I discovered the param shelveid by chance. It doesn't seem to be mentioned in the docs. Or did I miss it ? All the best Fred
  14. Hi, In Linux GTK client version 5.4.16.680 when I click on "Changesets" to view the changesets, I noticed the 4th column named Branch doesn't display branch names for each changeset. Can we assume this display will be restored in a future release ? Thanx Fred
  15. Hi, Using the linux GTK client version 5.4.16.680 I have successfully sync'd my plastic repo with a remote git repo. And today I got the following message : Receiving references... | - branchA: Local changes (36318ad) - branchB: Up to date (8232360) Receiving references... \The branch(es) /main has more than one head. Please, merge it to be able to continue synchronizing I have looked for corrective actions without success. Does this issue requires action on the plastic repo or the git repo ? Thanks Fred
  16. Xorcist

    Plastic for ARM?

    I'm running Lubuntu 14.04 LTS on an ARM device (Samsung Exynos5422 Cortex-A15 Processor). Does plastic have a build for ARM? If not has anyone sucessfuly run Plastic using QEMU or ExaGear? If so, how well does it work?
  17. naris

    eclipse for linux broke

    Since the ubuntu packages have been updated to remove the non-native plastic command and replaced it with gtkplastic, I am no longer able to use the eclipse plugin on my ubuntu system as it is no longer able to start the plastic program that was replaced. I now get this error message when I click the "Diff Changeset" menu item from a changeset in the branch explorer inside eclipse: There was a problem between the IDE and Plastic SCM communication through the console. Cannot run program "plastic" : error=2, No such file or directory Oddly enough, other operations do work inside eclipse, such as the branch explorer itself, checking files in & out, viewing history, etc. I suspect that a new version of the eclipse plugin might be required. Unfortunately ever since the linux version was migrated to packages instead of an installer there does not seem to be any way of obtaining the eclipse plugin on linux systems other than sending an e-mail to support. This really is not acceptable, there should at least be a way to obtain the eclipse plugin form the eclipse marketplace, an eclipse update site or at least a way to download a zip file of the most recent version or something. I have created a suggestion to do this (http://plasticscm.uservoice.com/forums/15467-general/suggestions/7276470-provide-a-way-to-get-eclipse-integration-for-linux).
  18. Hello PlasticSCM community, One of the functionalities I very much appreciate in other VCS programs is the ability to prepare an index before committing. Git has this by default, and one can add individual hunks to the index via git add -p and Mercurial has this through the built-in "Record Extension": $ git add --patch # or -p, but I use --patch for illustrative purposes ... [Add this hunk? y/n/q] n ... [Add this hunk? y/n/q] y I'm still learning PlasticSCM, but I don't see anything that is obviously this functionality in the Linux/GTK GUI. How can I add individual hunks to what I actually commit? Thanks, Kevin
  19. Hello Plastic Community, New user of PlasticSCM here, but not new to DVCS. I'm attempting to install and use PlasticSCM for the first time on this Linux machine, but I'm encountering a client crash. The short description: Plastic ($ plastic) crashes if I attempt to setup an SSL connection. I've attached the command line output form the crash. Help, please. The background: I'm running Ubuntu 14.10. I've installed the Linux client per the Plastic instructions. Checking ps waux, the plasticd process is running. I used scm.[ourserver].com:8088 I checked the "Use encryption (SSL)" checkbox I clicked the "Connect" button At this point, the process pops up a new window, then crashes before drawing anything in it. The title of this popup window is "Hostname mismatch in secure connection". I'm new to Plastic, but very well versed in Linux, administration, and DVCS in general, so any further information I can provide, or suggestions for how to fix this issue would be much appreciated. Thanks! Kevin crash_info.txt
  20. I have upgraded Plastic to 5.4.16.639 (with a shiny new Enterprise license) on an Ubuntu 14.10 system using "apt-get install plasticscm-client plasticscm-server" after adding the the 5.0 & 5.4 ubuntu repositories and it works really well. I also installed the plasticscm-client-gtk, but have been unable to start the native GTK GUI The plastic command works, but that is clearly the old mono client. There is also a gtkplastic executable in the /opt/plasticscm5/cleint directory, but executing that displays this error in the console: WARNING: The runtime version supported by this application is unavailable. Using default runtime: v1.1.4322 ** (/opt/plasticscm5/client/gtkplastic.exe:8992): WARNING **: The class System.Collections.Generic.List`1 could not be loaded, used in mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089 Unhandled Exception: System.TypeLoadException: Could not load type 'System.Collections.Generic.List`1' from assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'. Is there something else that I need to do to use the linux native client? Also, is there any way to install/upgrade the eclipse plugins in linux? I currently have the old eclipse plugin that was installed back when the linux client was available to be downloaded as an installer that would display a dialog box similar to the windows installer that allowed eclipse to be selected & prompt for the location of eclipse and install the plasticscm plugin. Ever since the linux version moved to repositories this no longer seems possible. Also, the client zip installer does not contain the eclipse plugin.
  21. Hi, I was wondering whether I was allowed to publish Dockerfile with accompanying files, or even the image itself in the docker hub for plastic scm server. I have managed to create an image for version 5.4.16.619. Though I am not that familiar with linux or docker and it is tailored to my needs - UP mode, hardcoded password, postgres db only. I was unable to make apt-get installation to work, so I went with mono image and server binaries (wget'ed from https://www.plasticscm.com/download/5.4.16.619/plasticscm/linux_x64/serverzip during the build).
  22. Hello, I am trying to install Plastic 5.4 on an Amazon EC2 server running Ubuntu 14. I am running into a lot of problems. My current one is when I run "sudo apt-get install plasticscm-client plasticscm-server" I get dependency errors (listed below). I am very new to this so if anyone has some beginner advice it would be very much appreciated! The following packages have unmet dependencies: plasticscm-client : Depends: plasticscm-mono3-runtime (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-libmono3-2.0-1 (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-libmono3-profiler (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-2.0-gac (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-4.0-gac (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-2.0-service (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-4.0-service (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-libmono3-cil-dev (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-utils (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-mono3-devel (= 3.0.3.1-1.1) but it is not installable Depends: plasticscm-libgdiplus (= 2.10.1-4) but it is not installable Depends: plasticscm-zlib1g (= 1:1.2.3.5) but it is not installable Depends: plasticscm-zlib1g-dev (= 1:1.2.3.5) but it is not installable
  23. Hi, would be great if server component won't delete / override the server configuration everytime it gets updated! This is really a no-go! Beein forced to restore server configuration after update will "force" the administrator to not do an update anymore. Can you also please (link) config to some /etc directories which is common and expected. Thank you ~Marcel
  24. Hello, I am trying to install Plastic SCM v4.1 on Ubuntu 14.04 LTS. I have tried the 64bit version but understand from reading the forums that this has issues. Have tried to install the 32bit version but the .run refuses to execute. In a last Google attempt I found this page: https://www.plasticscm.com/plastic-for-linux/index.html. I thought this would solve my issues as being able to use the package manager is always preferred. After following the guide above I get the following error. The following packages have unmet dependencies. plasticscm-client : Depends: plasticscm-libmono3-cil-dev (<= 3.0.3.1-1.1) but it is not going to be installed Depends: plasticscm-mono3-devel (<= 3.0.3.1-1.1) but it is not going to be installed Depends: plasticscm-libgdiplus (<= 2.10.1-4) but it is not going to be installed E: Unable to correct problems, you have held broken packages. Does anyone know where these packages are? and why they are not located in the public repository? Thanks in advance.
  25. Hello, I've configured the tool as shown on http://www.semanticmerge.com/documentation/main.shtml#CommandLineClientConfiguration of course updated the path and others. I've run into 2 errors: There were line ending errors, and some changes in the class annotation, and the tool cannot solve it via intelligent way, and the text merge tool cannot started "no text merge tool have been specified" Some png's are missing from /opt/semanticmerge/icons/java GLib.GException: Failed to open file '/opt/semanticmerge/icons/java/namespace.png': No such file or directory at Gdk.Pixbuf..ctor (System.String filename) [0x00000] in <filename unknown>:0 at SemanticGtk.DeclarationImages.GetPixbuf (e6 declaration, Language fileLanguage) [0x00000] in <filename unknown>:0 at SemanticGtk.TreeBuilder.b (Gtk.TreeViewColumn A_0, Gtk.CellRenderer A_1, TreeModel A_2, TreeIter A_3) [0x00000] in <filename unknown>:0 at GtkSharp.TreeCellDataFuncWrapper.NativeCallback (IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data) [0x00000] in <filename unknown>:0 GLib.GException: Failed to open file '/opt/semanticmerge/icons/java/namespace.png': No such file or directory at Gdk.Pixbuf..ctor (System.String filename) [0x00000] in <filename unknown>:0 at SemanticGtk.DeclarationImages.GetPixbuf (e6 declaration, Language fileLanguage) [0x00000] in <filename unknown>:0 at SemanticGtk.TreeBuilder.b (Gtk.TreeViewColumn A_0, Gtk.CellRenderer A_1, TreeModel A_2, TreeIter A_3) [0x00000] in <filename unknown>:0 at GtkSharp.TreeCellDataFuncWrapper.NativeCallback (IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data) [0x00000] in <filename unknown>:0 GLib.GException: Failed to open file '/opt/semanticmerge/icons/java/namespace.png': No such file or directory at Gdk.Pixbuf..ctor (System.String filename) [0x00000] in <filename unknown>:0 at SemanticGtk.DeclarationImages.GetPixbuf (e6 declaration, Language fileLanguage) [0x00000] in <filename unknown>:0 at SemanticGtk.TreeBuilder.b (Gtk.TreeViewColumn A_0, Gtk.CellRenderer A_1, TreeModel A_2, TreeIter A_3) [0x00000] in <filename unknown>:0 at GtkSharp.TreeCellDataFuncWrapper.NativeCallback (IntPtr tree_column, IntPtr cell, IntPtr tree_model, IntPtr iter, IntPtr data) [0x00000] in <filename unknown>:0
×