Jump to content

Search the Community

Showing results for tags 'mac'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Plastic SCM
    • General
    • Installation and configuration
    • Unity 3D
    • Plastic SCM on Mac
    • Plastic SCM on Linux
    • Gluon
    • Git interop
    • Integrations
    • Community Edition
    • Branching and merging
    • Announcements
  • Plastic SCM 4.0 Beta (Closed)
  • Plastic Cloud
    • General
    • Configuration
  • SemanticMerge
    • General
    • License
    • SCM's configuration
    • Share your experience!
    • External Parsers
  • GitJungle
  • Method History for Subversion

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 22 results

  1. Hi there, So I downloaded Plastic to work with Unity and i really like it, but we're having some problems with cloud sync. 1. There's no way to check on the cloud what's actually up there. Example: I've pushed 4 change sets, but he only sees 3. There's no way to go to the cloud and verify that my push was successful, i have to use the plastic software, which simply says "up to date" 2. Very often the upload simply gets stuck. The progress bar will be stuck at any range of numbers from 0%-99% and never move again, regardless of how much time goes by. There's no other way to see whats going on 3. Very often checking the sync to cloud tab, and opening the remote host, it simply says "Loading..." and never refreshes, and i am unable to do anything at that point because i obviously cannot update until its done loading, but it never finishes. What if anything can i do about all this?
  2. Hiho. Most of our team is working on Windows, but we also have a few Mac users. Now every(?) time somebody commits something on a Mac, there will usually be several files that are unmodified, but are commited/need to be committed anyway, as they are marked as "Only filesystem permissions changed". In the diff window the info given is "Filesystem permissions changed from NOT_DEFINED to [...]". As we really don't care about these (our main platform is Windows, and all our projects use Unity), we'd like to be able to prevent these changes from being committed/recognized, as they create a lot of clutter, making the Plastic client harder to use for our Designers and so on. We didn't find a setting to influence this behaviour - is there another workaround (or CLI trick?) to have the Mac client and/or the whole database ignore all filesystem permissions? Thanks a lot! :o)
  3. Hi, I'm trying to install older version of plastic 5.0.44.X (freshly downloaded from https://www.plasticscm.com/download/5.0.44.767 -> Mac OSX -> Server installer) on macOs Sierra 10.12.3. I got a few errors about creating dynamic links during installation but it was only dynamic links. However when I'm trying to run the client I'm getting error: Error running /Applications/PlasticSCM/client/plastic --configure /Applications/PlasticSCM/config/mono_setup: line 12: xmodmap command not found same with line 14 16 18 and later on some unhandled expceptions How can I install plastic on my mac? I managed to install the newest version before, but my server runs on 5.0.44 and I got an error that version is incompatible. EDIT: /Applications/PlasticSCM/config/mono_setup: line 12: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 14: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 16: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 18: xmodmap: command not found Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.WindowsFormsSynchronizationContext ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.ThemeEngine ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Windows.Forms.ThemeWin32Classic ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.KnownColors ---> System.TypeInitializationException: An exception was thrown by the type initializer for System.Drawing.GDIPlus ---> System.DllNotFoundException: /Applications/PlasticSCM/mono/Versions/2.6.4/lib/libgdiplus.dylib at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&) at System.Drawing.GDIPlus..cctor () [0x00000] in <filename unknown>:0 --- End of inner exception stack trace --- at System.Drawing.Graphics.FromHdcInternal (IntPtr hdc) [0x00000] in <filename unknown>:0 at System.Windows.Forms.XplatUIX11.Finalize () [0x00000] in <filename unknown>:0 --- End of inner exception stack trace --- at System.Drawing.Color.get_Black () [0x00000] in <filename unknown>:0 at System.Windows.Forms.ThemeWin32Classic..cctor () [0x00000] in <filename unknown>:0 --- End of inner exception stack trace --- at System.Windows.Forms.ThemeVisualStyles..ctor () [0x00000] in <filename unknown>:0 at System.Windows.Forms.ThemeEngine..cctor () [0x00000] in <filename unknown>:0 --- End of inner exception stack trace --- at System.Windows.Forms.SystemInformation.get_MenuAccessKeysUnderlined () [0x00000] in <filename unknown>:0 at System.Windows.Forms.Control..ctor () [0x00000] in <filename unknown>:0 at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:.ctor () at System.Windows.Forms.WindowsFormsSynchronizationContext..cctor () [0x00000] in <filename unknown>:0 --- End of inner exception stack trace --- at System.Windows.Forms.Control..ctor () [0x00000] in <filename unknown>:0 at System.Windows.Forms.ScrollableControl..ctor () [0x00000] in <filename unknown>:0 at System.Windows.Forms.ContainerControl..ctor () [0x00000] in <filename unknown>:0 at System.Windows.Forms.Form..ctor () [0x00000] in <filename unknown>:0 at System.Windows.Forms.MessageBox+MessageBoxForm..ctor (IWin32Window owner, System.String text, System.String caption, MessageBoxButtons buttons, MessageBoxIcon icon, Boolean displayHelpButton) [0x00000] in <filename unknown>:0 at System.Windows.Forms.MessageBox+MessageBoxForm..ctor (IWin32Window owner, System.String text, System.String caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton, MessageBoxOptions options, Boolean displayHelpButton) [0x00000] in <filename unknown>:0 at (wrapper remoting-invoke-with-check) System.Windows.Forms.MessageBox/MessageBoxForm:.ctor (System.Windows.Forms.IWin32Window,string,string,System.Windows.Forms.MessageBoxButtons,System.Windows.Forms.MessageBoxIcon,System.Windows.Forms.MessageBoxDefaultButton,System.Windows.Forms.MessageBoxOptions,bool) at System.Windows.Forms.MessageBox.Show (IWin32Window owner, System.String text, System.String caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton) [0x00000] in <filename unknown>:0 at Codice.I3.I3MessageBox.Show (IWin32Window window, System.String text, System.String caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton) [0x00000] in <filename unknown>:0 at Codice.I3.I3MessageBox.Show (System.String text, System.String caption, MessageBoxButtons buttons, MessageBoxIcon icon, MessageBoxDefaultButton defaultButton) [0x00000] in <filename unknown>:0 at ce.a (System.String A_0, System.String A_1, MessageBoxIcon A_2, IWin32Window A_3) [0x00000] in <filename unknown>:0 at ce.a (System.String A_0, System.String A_1, MessageBoxIcon A_2, ISynchronizeInvoke A_3, IWin32Window A_4) [0x00000] in <filename unknown>:0 at ce.a (System.String A_0, MessageBoxIcon A_1, ISynchronizeInvoke A_2, IWin32Window A_3) [0x00000] in <filename unknown>:0 at ce.a (System.String A_0, System.Exception A_1, MessageBoxIcon A_2, ISynchronizeInvoke A_3, IWin32Window A_4) [0x00000] in <filename unknown>:0 at ce.a (System.String A_0, System.Exception A_1, MessageBoxIcon A_2) [0x00000] in <filename unknown>:0 at ce.b (System.Exception A_0) [0x00000] in <filename unknown>:0 at xk.a (System.String[] A_0) [0x00000] in <filename unknown>:0
  4. v2k

    OSX Cloud Client

    I'm trying to configure a new cloud client on OSX. I've downloaded and installed the cloud package. When I try to sync the project, it sits at 0 bytes as the encryption is not working. I have a plasticd.lic file. I copied it into: /Applications/PlasticSCMServer.app/Contents/MonoBundle I tried to follow this guide: https://www.plasticscm.com/documentation/administration/plastic-scm-version-control-administrator-guide.shtml#Serverconfiguration But the first step points to a path/file that does not exist: /Applications/PlasticSCMServer.app/Contents/Applications/clconfigureserver.app/Contents/MacOS/clconfigureserver that folder doesn't exist, nor does the clconfigureserver file anywhere. How do I setup my client so I can pull the project?
  5. Hey there, I've been using plastic scm client from a windows pc for the longest time and the experience has been quite nice. I've recently migrated to mac, and the UI aren't quite identical. Specially, in the Changesets tab, is there any way to see on which changeset am I currently active? On a windows pc, active changeset used be in in bolded text.
  6. TheWanderingTree

    Mac OS X can't open Preferences in GUI

    I've just installed Plastic SCM Cloud Edition on Mac (Version 5.4.16.768) and when I open the app and go to Plastic SCM > Preferences, nothing happens. The preferences window does not open. Is this a bug, or am I missing something? Thanks!
  7. rigby44

    Reset macplastic

    Hi I have changed some of my preferences in macPlastic and I would like to reset them to the defaults. Does anyone know how to do this. I have tried reinstalling macplastic, but the preferences don't change. Many thanks James
  8. Hi, I shelve some changes and I want to apply them now, but I can't view or show shelves on Mac
  9. chaunceygardner

    Mac + PC setup

    I'm trying to get Plastic set up to work between my Mac, PC and Plastic Cloud and have an initial question - Should I be running local servers on both computers, and then using the sync replication to push/pull changes each make, or just have both comps connect directly to the plastic cloud server?
  10. Aveon

    Invalid login, mac

    Hello, my apologies as I'm not always that tech savvy, and this may be a bit of a newbie question I'm posting because a team member gave me a username, password, and server address info to access for our work, but when I used the log-in at the initial start-up screen it came out as invalid when i checked it, so out of curiosity I clicked log-in and it did allow me into the general ui where I can create repository's/workspaces, except whenever I go to connect to the server now it claims my username is invalid. I've been pouring through many of the guides that are available to see if I could figure out where I went wrong, but to no avail. I know this is problem a simple error but I can't seem to figure out the solution. Any feed back is appreciated!
  11. Our Mac user is experiencing following behavior with checkin in a new changeset. If there are no new changeset of other users he has no problem checkin in his changes, if there are new changeset then the pending changes view starts checkin in, it refreshes but nothing was checked in all the files remain in the pending changes view. We have a working solution but it's a bit hard in comparison with our windows users: Shelve the changes and move your workspace to the latest changeset and then apply your shelve and then the checkin will be a succes. Is this a know bug?
  12. Hi, Today I tried to install the latest version of Plastic (5.4.16.693) on my macbook pro running the last beta of OS X El Capitan. However the installation fails at the end. I looked through the installation log file: tail -n 200 /var/log/install.log And found the following: Sep 27 11:06:07 mac installd[308]: PackageKit: Executing script "./postinstall" in /private/tmp/PKInstallSandbox.VmSjLM/Scripts/com.codicesoftware.plasticscm.macplastic.rFNjcO Sep 27 11:06:07 mac installd[308]: ./postinstall: /tmp/PKInstallSandbox.VmSjLM/Scripts/com.codicesoftware.plasticscm.macplastic.rFNjcO/postinstall: line 2: /usr/bin/PlasticSCMUnityPlugin: Operation not permitted Sep 27 11:06:07 mac installd[308]: ./postinstall: /tmp/PKInstallSandbox.VmSjLM/Scripts/com.codicesoftware.plasticscm.macplastic.rFNjcO/postinstall: line 3: /usr/bin/PlasticSCMUnityPlugin: Operation not permitted Sep 27 11:06:07 mac installd[308]: ./postinstall: chmod: /usr/bin/PlasticSCMUnityPlugin: No such file or directory Sep 27 11:06:07 mac install_monitor[6403]: Re-included: /Applications, /Library, /System, /bin, /private, /sbin, /usr Sep 27 11:06:07 mac installd[308]: PackageKit: releasing backupd Sep 27 11:06:07 mac installd[308]: PackageKit: allow user idle system sleep Sep 27 11:06:07 mac installd[308]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “macplastic-5.4.16.693.pkg”." UserInfo={NSFilePath=./postinstall, NSURL=file://localhost/Users/andersl/Downloads/macplastic-5.4.16.693.pkg#com.codicesoftware.plasticscm. It seems there is something with the installation of the Unity plugin script in /usr/bin/ that fails due to not having the correct permissions (I was root) this might be something new on El Capitan (OS X 10.11). I don't use Unity anyway so I created a workaround that works for me: First I unpacked the downloaded installation .pkg file with: pkgutil --expand macplastic-5.4.16.693.pkg macplastic Then I opened the post install script with nano: nano macplastic/com.codicesoftware.plasticscm.macplastic.pkg/Scripts/postinstall I removed everything regrind the Unity plugin and only left the first line in the file: #!/bin/bash Finally I flattened the directory to a new .pkg file: pkgutil --flatten macplastic macplastic.pkg By double clicking this new .pkg file I could install the Plastic SCM client. However note that the Unity plugin does not work. /Anders
  13. I am looking for a download of the x11 version of the OSX 5.4 plastic client but I cannot find a download link anywhere, can someone point me to where this might be?
  14. How do you properly set up the launch command for the diff and merge tools in PlasticSCM on OSX? I've looked through the manual and searched the forums with no solution. I can't get PlasticSCM to launch SemanticMerge. It's probably because I don't have the diff/merge tool configured properly in PlasticSCM. I've added it as an "External diff tool" with the command: "/Applications/semanticmerge.app" -s="@sourcefile" -sn="@sourcesymbolic" -d="@destinationfile" -dn="@destinationsymbolic" -i="@comparationmethod" -e="@fileencoding" -edt=default I've also tried supplying semanticmerge.exe inside the app folder, with no luck.
  15. If I just start the SemanticMerge application, then hit "cancel" on the launch screen, it puts the app into a nonresponsive state. This is on Mac OS X 10.8.5. (Sorry, I tried to attach the hang log, but the forum doesn't allow it.)
  16. jdyeager

    Unity3D Branch Explorer Freeze

    Any time I try to use the branch explorer from the Unity3D plugin on a Mac, the window opens but then freezes. Usually I cannot do anything with it at all (including closing it or dragging it on the screen by the title bar). Sometimes I will be able to start moving the scroll bar up or down, but then all input will stop. My only option when this happens seems to be killing XQuartz. Any ideas on why this might be happening? Or where I should be looking for any errors that might be thrown?
  17. I have a new install of PlasticSCM on OS X 10.9 via PlasticSCM-5.0.44.506-osx-installer.app.zip. I had to install XQuartz 2.7.5 (xorg-server 1.14.4) When I run 'Server configuration' from /Applications, I can go through all the screens just fine. When I get to the end, there is a hypelink in the text that is supposed to allow me to change my database targets and perform a migration. In my case, I want to go from SQLite to PostgreSQL. However, when I click that link, nothing happens. I have re-started the 'plasticsd' process many times. I have run Server configuration many times. I have rebooted my iMac. No matter what, nothing happens when I click that link. Please advise. I am excited to use this product but, given project timelines, will have to look for alternatives if things do not improve soon. Thanks in advance. NJ
  18. oferei

    Is GitSync supported on Mac?

    I've seen in many places, including on Plastic SCM's site that GitSync is for Windows. Does this imply that it is not supported on Mac? And is it even out yet? Is it included in normal Plastic SCM installations?
  19. Hi, I have been happily using Plastic on Windows in standalone mode (through localhost) and now have to test some stuff on MacOS. So I installed the MacOS client (same version as server) over Mountain Lion and was then able to browse the existing repositories and their changesets for instance. But I can't update any newly created workspace. I get the following error: Dialog box titled: Update Results / This report shows possible problems found during the update operation > "No channel found trying to connect" I can't read the end of the message so, positioned in a workspace top directory, I issued the following on the command line: cm update . And get the following (strange) message: No channel found trying to connect to [localhost:8087 (unreachable)] Strange because it's trying to connect to localhost instead of the IP address of the server, set in the selector. Server side the following shows up in the log : 2013-07-17 22:14:21,025 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 631|rect: 0|sentb: 577|sendt: 0|prt: 63|th: 5724|dest: 0|mt: 63|sert: 0|zip: 0| 192.168.0.17|GetItemInfo 2013-07-17 22:14:22,813 00000000-0000-0000-0000-000000000000 NT AUTHORITY\SYSTEM at Freds-Mac.local INFO Security - Get ACL. Object id:2@rep:11. ACL ID 0 2013-07-17 22:14:22,815 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 1492|rect: 0|sentb: 900|sendt: 0|prt: 62|th: 1632|dest: 0|mt: 62|sert: 0|zip: 0| 192.168.0.17|CalculateACL 2013-07-17 22:14:33,340 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 1067|rect: 0|sentb: 349|sendt: 0|prt: 0|th: 7824|dest: 0|mt: 0|sert: 0|zip: 0| 192.168.0.17|GetTriggerList 2013-07-17 22:14:33,345 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 1067|rect: 0|sentb: 349|sendt: 0|prt: 0|th: 5724|dest: 0|mt: 0|sert: 0|zip: 0| 192.168.0.17|GetTriggerList 2013-07-17 22:14:33,350 00000000-0000-0000-0000-000000000000 NT AUTHORITY\SYSTEM at Freds-Mac.local INFO Operations - Get info for branch /main at repository ID 11 2013-07-17 22:14:33,363 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 639|rect: 0|sentb: 614|sendt: 0|prt: 15|th: 1632|dest: 0|mt: 0|sert: 15|zip: 0| 192.168.0.17|GetBranchInfoByName 2013-07-17 22:14:33,365 00000000-0000-0000-0000-000000000000 NT AUTHORITY\SYSTEM at Freds-Mac.local INFO Operations - Get info for branch 3 at repository ID 11 2013-07-17 22:14:33,375 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 853|rect: 0|sentb: 614|sendt: 0|prt: 0|th: 7824|dest: 0|mt: 0|sert: 0|zip: 0| 192.168.0.17|GetBranchInfo 2013-07-17 22:14:33,380 00000000-0000-0000-0000-000000000000 NT AUTHORITY\SYSTEM at Freds-Mac.local INFO Operations - Get info for branch /main at repository ID 11 2013-07-17 22:14:33,388 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 639|rect: 0|sentb: 614|sendt: 0|prt: 0|th: 5724|dest: 0|mt: 0|sert: 0|zip: 0| 192.168.0.17|GetBranchInfoByName 2013-07-17 22:14:33,400 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 653|rect: 0|sentb: 3312|sendt: 0|prt: 0|th: 1632|dest: 0|mt: 0|sert: 0|zip: 0| 192.168.0.17|GetLastChangesetTreeOnBranch 2013-07-17 22:14:33,408 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 1067|rect: 0|sentb: 349|sendt: 0|prt: 0|th: 7824|dest: 0|mt: 0|sert: 0|zip: 0| 192.168.0.17|GetTriggerList 2013-07-17 22:14:37,306 00000000-0000-0000-0000-000000000000 NT AUTHORITY\SYSTEM at Freds-Mac.local INFO Operations - Retrieving server instance Id 2013-07-17 22:14:37,306 NT AUTHORITY\SYSTEM at INFO ChannelCall - recb: 617|rect: 0|sentb: 399|sendt: 0|prt: 0|th: 5724|dest: 0|mt: 0|sert: 0|zip: 0| 192.168.0.17|GetServerInstanceId 2013-07-17 22:15:07,890 (null) NT AUTHORITY\SYSTEM at (null) INFO Channel - Tcp transport error. ReceiveMessageStatus Connection closed 2013-07-17 22:15:07,890 (null) NT AUTHORITY\SYSTEM at (null) INFO Channel - conn 32 Tcp transport error. Connection closed Fred
  20. Hello, A couple of issues Issue 1: I am trying to start the server on a Mountain Lion OS (X). When running 'plasticd' in Applications -> Plastic SCM -> server -> plastics, graphically, I get the following: Applications/PlasticSCM/server/plasticd ; exit; /Applications/PlasticSCM/config/mono_setup: line 12: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 14: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 16: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 18: xmodmap: command not found when, under the same directory clicking on 'plasticsd' I get the following: /Applications/PlasticSCM/server/plasticsd ; exit; Usage: {start|stop|status|restart|help} logout [Process completed] Using command line: plasticd start /Applications/PlasticSCM/config/mono_setup: line 12: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 14: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 16: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 18: xmodmap: command not found plasticsd start Starting PlasticSCM server: /Applications/PlasticSCM/config/mono_setup: line 12: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 14: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 16: xmodmap: command not found /Applications/PlasticSCM/config/mono_setup: line 18: xmodmap: command not found OK Also the following: sudo mono plasticd.exe --console --stack Password: sudo: mono: command not found I ran this because I noticed in another thread that it was one of the commands being asked for. When I go to the /mono directory and run the same command as above it complains that it cannot find plasticd.exe Showing that all plastic processes are not running: $ ps -fA | grep plasticd 501 34465 34001 0 4:59AM ttys001 0:00.00 grep plasticd What is the way to start the server on the Mac. Issue 2: I had the client configured to communicate to a server in my Win 7 machine and had a local workspace, which worked. Now I want to (and did) configure the client to communicate to the local Mac machine (MachineName.local with port 8087) which in turn tries to load the local workspace immediately which is configged to the Win machine. Is there a way to erase or start the client where it prompts me to create a new workspace. Thank you.
  21. I just updated to the latest Mac Client, and when i restarted after install, the client is completely locked up. I tried to find any config files that had local client config in them and reset them, but the client always comes up in the same non-functional state. I've also uninstalled & reinstalled a number of times, but the client always comes up in the same bad state. I really can't work until I can apply some shelved changes to my workspace. Any suggestions? Paul
  22. sray

    PlasticSCM on Mac

    I've been using version 4 on the PC platform and like the new UI very much. I just installed on a Mac and see it uses a very dark color scheme. Is there any way to change this to the lighter colors used on the PC version? Thanks, Steve
×