Jump to content
aesthetic

Cant connect to repo server from other pc

Recommended Posts

aesthetic    0

I'm trying to join a repo server from my laptop through the client configurator and the main server is not being recognised. Do I need to make a completely new workspace and repository to connect to a local network server? Did I not properly port forward? Do I need a hardware key to join? I've already set unity for use with plastic scm I'm just having detection issues. I have it set to username and password for authentication and the server is ran on my windows desktop. Also, do multiple computers count as multiple users? 

I'm also running two seperate routers connected to each other(hence the local ip of 192.168.2.2) Might that be conflicting?

Untitled.png

Share this post


Link to post
Share on other sites
calbzam    45

Hi,

Please open the Plastic configurator "plastic --configure" and try to connect to your "SERVER:port" clicking on the "Check Connection" button. You don't need to create a workspace, a repository or a hardware key to connect to the server. You just need that the client is able to access to this server and port. If the check connection is not working, I would review your network configuration.

Multiple computers don't count as multiple users (in terms of licese) if you have configured the same Plastic user. 

Regards,

Carlos.

Share this post


Link to post
Share on other sites
aesthetic    0

I disconnected my secondary router and ran my repository server through the main router. It worked perfectly fine for connecting and connecting from other locations. Now I have a problem where my repository and all it's data will not load, but it claims it is connected and on that servers repository. Not entirely sure what to do here or if I am missing something. It automatically connects and is connected to default repository (which is not actually the name of my repository I branched on) Do I need to do a sync view?

Share this post


Link to post
Share on other sites
aesthetic    0

The server uses username/password but my client configuration tool only uses computer username for verification. I'm pretty sure I was actually connecting to my laptops own server, which is weird. Both "servers" have the exact same name and that might explain why I thought I was connected. How do I configure the client configurator to use username and password rather than the windows pc name?

Share this post


Link to post
Share on other sites
calbzam    45

Hi,

When you open the client configurator "plastic --configure", after entering your server name and port, when you click on the "Check connection" button, it will connect to the server and authomatically detect the server authentication mode. If the server is configured to use user/password, you will be requested to enter your user/password credentials.

Please also review that your server is configured to use user/password. You can run "configureserver.exe" to review the server configuration and re-configure it if necessary.

Regards,

Carlos.

Share this post


Link to post
Share on other sites
manu    146

Hello @aesthetic,

It seems you are having network issues, I think the Plastic SCM client requests can't reach the Plastic SCM server.

what happens if you click the "Connect" button? Can you please enable the Plastic GUI log: https://www.plasticscm.com/documentation/technical-articles/kb-enabling-logging-for-plastic-scm-part-i.html and send the log generated after clicking the "Connect" button?

Can you also run the following command:

cm lrep 97.91.134.79:8087

and tell us what happens?

Thanks.

Share this post


Link to post
Share on other sites
aesthetic    0

I'm pretty sure I'm missing some sort of verification to connect to the default repository on the server. Any form of port forwarding I'm missing? Windows firewall? Not even UDP local network allows me to link my client to the server. Do I need 2 users if one is (probably)constantly in use on the server?

image.png

Share this post


Link to post
Share on other sites
manu    146

From your screen shot I think I'm right if I say it's because network issues, it's a timeout so the client can't talk with the server.

Yes, the Windows firewall usually blocks the outgoing traffic. You can try to temporarily disable it and give it a try, if it works then you can re-enable it and add an exception rule.

No, you don't need two Plastic users for this test.

Are you using Plastic from Home? Is the Plastic server at your office? Are you using Plastic from the office? I'm wondering if you can count with an IT team to debug the problem. From what I see it's "just" a network problem. You can start trying to ping the server machine, are you able to do it? Then you can try to telnet to the 8087 port to check if it's reachable.

 

Share this post


Link to post
Share on other sites
aesthetic    0

I use it from home(On a desktop) and purchased a laptop for when I'm at college. Plastic scm only says "Cannot retrieve license information" on my laptop, while my desktop repository functions perfectly fine. I can scan and find my repository perfectly fine through local udp, but I can't actually connect and I get that license error. If I recall correctly I got the same error trying to connect to the laptop. Port is closed when trying to connect from a different network, and I triple checked my network configuration. I may have slipped up on the port or ip address of my system but I shouldn't be getting those errors when locally connecting. I even switched over to my main router, incase of conflict but I never had that issue with other server port forwarding(worth a try). One thing to note is the laptop is also hosting a server in the background, which I do not want it to do; so maybe a laptop fresh install will be the best route now that I'm aware of some other things.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×