Jump to content
AidanDiffey

Icon 'unknown' not present in theme

Recommended Posts

Hello.

I have recently updated Plastic on Linux (Centos running XFCE) to version 6.0.16.1746 and when I access the branch explorer I get the following error:

Icon 'unknown' not present in theme

I also cannot see the branch explorer.

 

Please can you tell me how to resolve this issue?

Share this post


Link to post
Share on other sites

I have turned on DEBUG and the following appears in the log

 

2017-11-11 13:34:09,828 (null) <> at (null) ERROR Program - The runtime is terminating [False]
2017-11-11 13:34:09,829 (null) <> at (null) ERROR ExceptionHandler - [HandleUnhandledGLibException] Unexpected error: Icon 'unknown' not present in theme
2017-11-11 13:34:09,829 (null) <> at (null) DEBUG ExceptionHandler - Stack trace:   at Gtk.IconTheme.LoadIcon (System.String icon_name, System.Int32 size, Gtk.IconLookupFlags flags) [0x00048] in <dc5edc3cf5244a9e8b6ef8d8ca6b6434>:0
  at bo.a (System.String A_0) [0x0003d] in <b48bffa5818e4d8d8a303d22fd4c7656>:0
  at bo.h (System.String A_0) [0x00007] in <b48bffa5818e4d8d8a303d22fd4c7656>:0
  at x0.a (r6 A_0) [0x00097] in <b48bffa5818e4d8d8a303d22fd4c7656>:0

Share this post


Link to post
Share on other sites

OK.

I have fixed that issue now by selecting the Gnome icon set instead of the Adwaita icon set but I still cannot see anything in the branch explorer. 

Can anyone help with this?

Share this post


Link to post
Share on other sites

Hello @AidanDiffey,

I have some questions:

Can you tell me how did you upgrade Plastic?

How did you change the gnome icon to another one?

Can you also provide the log again?

Van you give the ls -l  -R output for the theme directory?

Thanks.

Share this post


Link to post
Share on other sites

>> Can you tell me how did you upgrade Plastic?
I ran the "sudo yum update" and it updated plastic. I have configured alot since then so I cannot see the history

How did you change the gnome icon to another one?
>> Using Xfce.  Applications -> Settings -> Appearance -> Icons.  I then selected Gnome instead of Adwaita

>>Can you also provide the log again?
What log do you require?

Van you give the ls -l  -R output for the theme directory?
>> Not sure where this is on Centos and Xfce.  Any ideas?

 

Share this post


Link to post
Share on other sites
25 minutes ago, AidanDiffey said:

What log do you require?

The log you initially enabled, you shared a few lines above this thread.

26 minutes ago, AidanDiffey said:

>> Not sure where this is on Centos and Xfce.  Any ideas?

This should be the path and the command to use: ls /opt/plasticscm5/theme/ -l -R

Share this post


Link to post
Share on other sites

Attached theme.txt is the output of ls /opt/plasticscm5/theme/ -l -R

Regarding the non existing branches, this appears to be different dependant on the project that I am connecting to.  I am trying to get more information from the log file.

Is there any way to downgrade to V5.4 of the client from the yum repo?

theme.txt

Share this post


Link to post
Share on other sites

Hi @AidanDiffey,

I have just checked and you are having all our icons correctly installed, can you provide me the application log? I want to check if we have more details about the missing icon.

20 hours ago, AidanDiffey said:

Regarding the non existing branches, this appears to be different dependant on the project that I am connecting to.

I don't understand this :S

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×