Jump to content
Christian Rademan

The server spec is not correct:

Recommended Posts

Hi there.

Our company has recently adopted plastic as our source control and we have started using it in Unity ( 5.6.3p1)

Enabling the plastic plugin on an empty project works and you can checkout, add etc in the editor.

If we try this on our actual project, the plugin disconnects and we get this error:

PlasticSCM : The server spec is not correct.

This does not happen on all the users machines, we have one or two that is working.

Setting Gluon mode tot true seems to fix the issue on these machines, but not others.

Can you assist?

Not sure If I should open a support ticket instead.

Thanks.

 

Share this post


Link to post
Share on other sites

@Christian Rademan, yes please open a support case and let's see if you can find out what's going on.

For the rest of users reading this, the first step is enabling the plugin log, so if you find yourself in this situation, please generate the log file for us. You just need to use the attached "plasticunity.log.conf.zip" file.

The .conf file you'll find inside will enable several internal logs, you need to unzip it, paste the .conf file inside the Plastic SCM client directory, close unity and force the issue. The logs will be generated at: c:\logs\unity (can be changed by editing the value inside the .conf file) . They will hopefully contain useful info about the issue, share them with us.

 

plasticunity.log.conf.zip

Share this post


Link to post
Share on other sites

Thanks!

I've seen this:

2017-11-13 13:52:07,948 DEBUG Commands - Assets path:       [C:\Dev\Invictus\FireTruck_Rhino\Assets]
2017-11-13 13:52:07,948 DEBUG Commands - ProjectSettings:   [C:\Dev\Invictus\FireTruck_Rhino\ProjectSettings]
2017-11-13 13:52:07,948 DEBUG Commands - Project root path: [C:\Dev\Invictus\FireTruck_Rhino]
2017-11-13 13:52:07,948 DEBUG Commands - Gluon mode:        [true]
2017-11-13 13:52:07,948 DEBUG Commands - Repository name:   []
2017-11-13 13:52:07,948 DEBUG Commands - Workspace name:    []

Are the "Repository name" and "Workspace name" fields empty at the Unity editor preferences too?

Share this post


Link to post
Share on other sites

Hello @scaslin,

I unfortunately never hear from Christian so I'm not sure if you may be facing the same issue.

Can you please give me the Unity version you are using? I would like to test it as closer as you do.

Also, can you please tell me how did you configure the workspace at this point?

unityConnect.PNG

Did you already have a Plastic SCM workspace? Did you create a new one?

Thanks.

Share this post


Link to post
Share on other sites

We are using Unity 2017.1.1p1 but the source control panel is different...so below

We only have the issue when we add .unity & .unity.meta to the lock rules and try to save out a scene file. We then get the error.

Steven

unityplastic.png.ace2fbd7665b2df733f1651d6cde7e3a.png

Share this post


Link to post
Share on other sites

You are having a different window since Unity is detecting a Plastic SCM workspace for your project path. You can set the "Gluon mode" to "False" and click connect, that should be enough.

Can you please enable the Plugin log as it's explained above in order to check if we are facing exactly the same issue?

I've been testing the plugin, having lock rules as you do and I can't reproduce the issue so far. I'll keep trying it.

Share this post


Link to post
Share on other sites

Sorry that it's taken me a while to get back to you on this.

Here's the log from a Unity test project.

We still have the exact issue with version 2017.2.0f3 of Unity.

"PlastSCM : The server spec is not correct:."

Hope this helps,

Thanks,

Steven

plasticunity.log.txt

plasticunity_api.log.txt

plasticunity_commands.log.txt

plasticunity_status.log.txt

plasticunitypipe.log.txt

Share this post


Link to post
Share on other sites

Hi @scaslin,

I've been trying to reproduce your problem but unfortunately I'm not able to make it fail.

Can you please tell me if you are available to schedule an online meeting in order to try to get it resolved? Please tell me you availability and timezone.

 

Share this post


Link to post
Share on other sites

So thanks to @scaslin we found an issue related with the exclusive checkout system, the webui and the Unity plugin.

We changed the lock.conf format to be able to accept and empty "lockserver:" parameter, this is 100% supported by the server and the regular clients (cm.exe, Plastic GUI and Gluon) but NOT by the Unity plugin.

We already fixed the problem and will be released asap (it's inside the release pipeline).

Share this post


Link to post
Share on other sites
Guest Wojciech Gołowkow
On 2/15/2018 at 12:00 PM, manu said:

We already fixed the problem and will be released asap (it's inside the release pipeline).

Will you let us know which version it is fixed in?

It's quite a crucial feature! :-)

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×