Jump to content
andsee

Finding pending changes stuck?

Recommended Posts

This morning has been spent trying to get Plastic to check in ~5GB of changes with no success :-(

It looked like Plastic was crashing so I force quit plastic a few times and then decided to roll back to the last v6 version of Mac Plastic.

Still this was taking a long time, however on looking at the Activity monitor I could see plastic was busy (100% of one cpu core) and the disk access was slowly going up. So I left it for an hour or more and eventually it started to show the uploading to server progress bars and no longer showed not responding in the force quit dialog. The bars slowly filled up until full and then it decided that it was going to cancel the operation.

So I decided to move all these new files out of the project and add just a few at a time. Unfortunately I've not been able to get pending changes to show any changes it just shows 'finding changes....' It's not accessing the HDD or network but it's CPU is at 100% :-(

As I test I thought I'd copy the whole project to another folder to see how long it should take to access all data (14GB) and it took just over a minute.

cm iostats
Performing network tests with server: xyz.com:8087. Please wait...
Upload speed   = 606.64 Mbps.   Time uploading  16MB = 211ms.      Server: xyz.com:8087
Download speed = 221.84 Mbps. Time downloading  16MB = 577ms.      Server: xyz.com:8087

Performing disk speed test on path: /var/folders/7d/0592g77j6fq_byykt4rvvvw40000gn/T/PlasticSCM_IOStats. Please wait...
Disk write speed = 455.516014234875 MB/s. Time writing  512MB = 1124 ms.
Disk read speed  = 1333.33333333333 MB/s. Time reading  512MB = 384 ms.

It's now 20 minutes since I switched to the Pending Changes tab and it still shows 'finding changes and 100% cpu with no further disk or network access'

This occurs in version 7.0.16.2063 and 6.0.16.1792

Andy

Share this post


Link to post
Share on other sites

Finally back up and running.

Restarting the server and updating to latest 7 had no effect.

To make progress and get the pending changes view working I deleted the .plastic file within the project and then created a new workspace in the same location and did a get.

I checked in a few files fine

I then proceeded to check in sections at a time (1Gb / 100,000 files or so a time).

This would cause 7.0.16.2063 to crash and exit every time, I sent the crash report via apple.

Switching back to 6.0.16.1792 and the checkins completed.

So there may be an issue within 7 when checking in large numbers of files.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×